読者です 読者をやめる 読者になる 読者になる

Masa / Lino Blog

Masanori Satoh ( Masa / Lino ) の徒然ブログです

MySQL/RubyでLoadError…

Ruby

Ruby単体でデータベースプログラムをやろうかと、gemを使ってMySQL/Rubyのmswin32版をインストール。
ところがrequire 'mysql'でモジュールのLoadErrorが発生…。


いろいろ調査した結果、MySQLに付属しているlibmySQL.dllのロード中にエラーが発生している模様。
エラーが発生するMySQL/RubyのバージョンとMySQLのバージョンはこんな感じ。

というかInstant Railsでは問題なく動作するので、手順は問題ないはず。

  1. MySQLのダウンロード
  2. MySQL_INST_DIR/binにパスを通す
  3. gem install mysqlmysql 2.7.3 (mswin32)を選択

というわけで、MySQLのバージョンを落としてみた。

上の組み合わせなら問題なく動作する。


こんなことではまるとは…。
おかげで寝不足になりました。